For Gauche 0.9.5


Next: , Previous: , Up: ライブラリモジュール - SRFI   [Contents][Index]

11.14 srfi-55 - require の拡張

Module: srfi-55

このモジュールでは require-extension マクロが定義されています。 これは、ポータブルなスクリプトを書くためのもうひとつ別の方法です。 指定した特性を確認する他の方法については、機能条件式 および機能ベースプログラム設定言語を見てください。

このモジュールは、require-extensionを使った際に自動的にロードさ れます。それゆえ明示的に(use srfi-55)する必要はありませんし、ポー タビリティのためにはするべきではありません。

Macro: require-extension clause …

clauseで指定した拡張を以降のプログラムで利用可能にします。

clauseは以下の形式になります。

(extension-id extension-arg …)

現時点では、srfiのみextension-idとして使えます。その引数 はSRFIの番号です。

たとえば、以下の

(require-extension (srfi 1 13 14))

は以下の Gauche の use 形式にほぼ対応します。

(use srfi-1)
(use srfi-13)
(use srfi-14)

Next: , Previous: , Up: ライブラリモジュール - SRFI   [Contents][Index]